Nous utilisons des cookies pour vous garantir la meilleure expérience sur notre site. Si vous continuez à utiliser ce dernier, nous considèrerons que vous acceptez l'utilisation des cookies. J'ai compris ! ou En savoir plus !.
Nom d'utilisateur    Mot de passe              Toujours pas inscrit ?   Mot de passe oublié ?

Annonce

Rencontres des Utilisateurs Francophones de QGIS 2019 à Montpellier

12 et 13 décembre 2019 à Montpellier.

Cet événement est organisé en partenariat entre Montpellier SupAgro et l’OSGeo-fr.

http://conf.qgis.osgeo.fr/

 

#1 Tue 13 August 2019 21:59

Serkis
Membre
Date d'inscription: 13 Aug 2019
Messages: 1

QGIS/Modeleur: couche vecteur temporaire

Bonjour,
J'ai une question et une impasse.

Voila dans le modeleur Qgis3 je créer un nouveau champs attribut avec cette formule.
    aggregate(
            layer:= 'Tampon',
            aggregate:='sum',
            expression:=Total,
            filter:=touches($geometry, geometry(@parent))
)

Le problème est que la couche 'Tampon'  est préalablement creer aussi par le modeleur.
Donc quand je "run" le modeleur la première fois cela ne marche pas car la couche "tampon" n'est pas encore "effective". La deuxième fois cela ne pose aucun problème.

Donc j'aimerai connaitre comment creer une couche virtuelle pour qu'elle soit directement utilisable dans le modeleur sur l'action suivante.

Donc ca marche mais je suis sur que l'on peut optimiser

Hors ligne

 

Pied de page des forums

Powered by FluxBB

Partagez  |