Nous utilisons des cookies pour vous garantir la meilleure expérience sur notre site. Si vous continuez à utiliser ce dernier, nous considèrerons que vous acceptez l'utilisation des cookies. J'ai compris ! ou En savoir plus !.
Nom d'utilisateur    Mot de passe              Toujours pas inscrit ?   Mot de passe oublié ?

Annonce

Mooc adress

MOOC Adresse du 4 au 29 novembre 2019

Formation en ligne à destination des élus et techniciens des communes et EPCI
Formation gratuite sur la plateforme FUN
Inscriptions

#1 Tue 03 September 2019 10:27

seb_89
Membre
Date d'inscription: 11 May 2018
Messages: 3

QGIS 3.4: Probleme d Utilisation des donnees WFS IGN

Bonjour,
J'utilise depuis plus d'un an les données WFS et WMS de l'IGN sous Qgis 2.8

Avec Qgis 3.4 pas de soucis pour les données WMS par contre cela ne fonctionne pas pour les données WFS.
j'accède bien au catalogue de l'iGN (URL et la clé de licence sont bon) mais impossible de charger les données .

j'ai un message de ce type :

Couche BDTOPO_BDD_WLD_WGS84G:surface_route: Le téléchargement des entités de la couche BDTOPO_BDD_WLD_WGS84G:surface_route a échoué ou partiellement échoué: Le téléchargement des entités à échoué: Error transferring https://wxs.ign.fr/XXXXXXXXXXXXXXXXXX/g … EPSG::4326 - server replied: Forbidden. Vous allez sans doute devoir recharger la couche avec F5

ci dessus, dans la retranscription du message j'ai remplacé ma clé de licence par XXXXXXXXXXXXXXXXXXX

Merci

Dernière modification par seb_89 (Tue 03 September 2019 10:28)

Hors ligne

 

#2 Thu 12 September 2019 12:49

Brice73
Membre
Date d'inscription: 28 Jun 2018
Messages: 17

Re: QGIS 3.4: Probleme d Utilisation des donnees WFS IGN

Bonjour

Je n'utilise pas les géoservices WFS de l'IGN, mais je rencontre un problème similaire avec un flux WFS de la DREAL Auvergne-Rhône-Alpes : https://carto.datara.gouv.fr/cgi-bin/mapservwfs? (srid 2154)

Aucun problème pour ouvrir les données sur Qgis 2.18, mais je n'y arrive pas sur Qgis 3.4. Le paramétrage de la connexion aux données est pourtant le même dans les 2 versions.
Dans le gestionnaire des sources, après avoir chargé le catalogue de donnée, quand je clique sur une donnée puis sur "ajouter", j'ai les messages d'erreur suivants (très similaire voir identique à celui de seb_89) :

Échec de la requête réseau DescribeFeatureType pour l'URL pageSize='0' pagingEnabled='true' restrictToRequestBBOX='1' srsname='EPSG:2154' typename='ms:l_zone_humide_int_s_d74' url='https://carto.datara.gouv.fr/cgi-bin/mapservwfs?' version='auto' table="" sql=: Le téléchargement du type d'entité à échoué: Error transferring https://datacarto.datara.gouv.fr/wfs/?S … _int_s_d74 - server replied: Not Found

Le téléchargement du type d'entité à échoué: Error transferring https://datacarto.datara.gouv.fr/wfs/?S … _int_s_d74 - server replied: Not Found


Ce qui est bizzare, c'est qu'il n'y a que pour ce flux que ça ne fonctionne pas. J'arrive très bien à accéder aux données du flux WFS du Sandre et du BRGM et comme seb_89, je ne rencontre pas non plus de problème sur les données WMS...

Si quelqu'un connaitrait la source du problème, nous sommes donc 2 à être preneur ;-)

Hors ligne

 

#3 Fri 13 September 2019 09:33

Charlybreizh
Membre
Lieu: Nantes
Date d'inscription: 28 Sep 2017
Messages: 12
Site web

Re: QGIS 3.4: Probleme d Utilisation des donnees WFS IGN

Bonjour,
J'ai eu le même souci (sur le flux WFS uniquement et avec Qgis 3.4).
Pour régler le problème, il faut éditer le flux IGN et changer la version dans les options WFS. Passez le en version 1.0 (il est à 'maximum' par défaut). Normalement ça marche.

Le problème ne se pose qu'avec Qgis 3, la version 2.18 n'a pas de soucis à priori. Il concerne aussi le flux du GPU (Géoportail de l'urbanisme) mais pas l'INPN ni le BRGM. Donc origine du problème inconnue pour moi...

Charles

Hors ligne

 

#4 Fri 13 September 2019 12:22

Brice73
Membre
Date d'inscription: 28 Jun 2018
Messages: 17

Re: QGIS 3.4: Probleme d Utilisation des donnees WFS IGN

De mon côté, en effet, c'était bien la version qui posait problème.

Merci beaucoup !

Hors ligne

 

Pied de page des forums

Powered by FluxBB

Partagez  |