Nous utilisons des cookies pour vous garantir la meilleure expérience sur notre site. Si vous continuez à utiliser ce dernier, nous considèrerons que vous acceptez l'utilisation des cookies. J'ai compris ! ou En savoir plus !.
Nom d'utilisateur    Mot de passe              Toujours pas inscrit ?   Mot de passe oublié ?

Annonce



#AGAURAGEO

1ère Biennale de l'Information Géographique
Lyon - 17 décembre 2019

http://agaurageo.fr/

#1 Sun 13 October 2019 14:06

preliator
Membre
Date d'inscription: 17 Nov 2018
Messages: 219

Installation PostGis sur PostGre

Bonjour à tous,

En tentant d'installer postgis sur mon SGBD PostGre, je me rend compte qu'il y a un problème d'installation.

En effet, lorsque je lance ce script :

Code:

CREATE EXTENSION postgis;

DROP TABLE IF EXISTS cite cascade;
CREATE TABLE cite (
    nom_cite varchar(80) primary key,
    geom_cite geometry
);

insert into cite values
('Storms End', ST_GeomFromText('POINT(0.378000 0.437000)')),
('Sunspear', ST_GeomFromText('POINT(0.224000 0.473000)')),
('Braavos', ST_GeomFromText('POINT(0.682000 0.618000)')),
('Casterly Rock', ST_GeomFromText('POINT(0.507000 0.162000)')),
('Gulltown', ST_GeomFromText('POINT(0.602000 0.510000)')),
('Highgarden', ST_GeomFromText('POINT(0.365000 0.239000)'));

Il me renvoie l'erreur suivante :

Code:

ERROR:  ERREUR:  n'a pas pu ouvrir le fichier de contrôle d'extension « C:/Program Files/PostgreSQL/12/share/extension/postgis.control » : No such file or directory

Sur des vidéos tuto d'installation de PostGis, ils l'installent avec StackBuilder après l'installation de PostGre. Cependant, je ne trouve pas l'onglet à cocher "Spatial" dans ce logiciel.

Je ne sais pas trop comment m'y prendre ...

Merci à vous

Dernière modification par preliator (Sun 13 October 2019 14:36)

Hors ligne

 

#2 Mon 14 October 2019 09:36

Theos2000
Membre
Date d'inscription: 15 Jun 2015
Messages: 157

Re: Installation PostGis sur PostGre

Bonjour quelle est la version de postgres que vous installez ?
Si c'est la 12 apparemment le .exe de postgis 3.0 n'est pas encore sorti et la version 2.5 semble incompatible.

Hors ligne

 

#3 Mon 14 October 2019 11:37

preliator
Membre
Date d'inscription: 17 Nov 2018
Messages: 219

Re: Installation PostGis sur PostGre

Merci pour votre réponse.
J'utilise la version 12 de Postgre effectivement. Dois-je installer une version ultérieure (la 11 par exemple ?)

Hors ligne

 

#4 Mon 14 October 2019 14:39

Theos2000
Membre
Date d'inscription: 15 Jun 2015
Messages: 157

Re: Installation PostGis sur PostGre

oui cela fonctionnera

Hors ligne

 

Pied de page des forums

Powered by FluxBB

Partagez  |