Nous utilisons des cookies pour vous garantir la meilleure expérience sur notre site. Si vous continuez à utiliser ce dernier, nous considèrerons que vous acceptez l'utilisation des cookies. J'ai compris ! ou En savoir plus !.
banniere

Le portail francophone de la géomatique


Toujours pas inscrit ? Mot de passe oublié ?
Nom d'utilisateur    Mot de passe              Toujours pas inscrit ?   Mot de passe oublié ?

#1 Wed 18 November 2020 14:46

Tan85
Membre
Date d'inscription: 20 Sep 2019
Messages: 2

Connexions des attributs qui sautent à chaque sauvegarde du projet

Bonjour,
voici mon problème :
à chaque fois que je sauvegarde mon projet .fmw et je quitte FME, quand je le rouvre mes connexions entre attributs sur les données de destination ont sautés ou elles sont fausses.
Je ne comprends pas pourquoi cela se produit.
Quand je rétablie les bonnes connexions mon projet marche sans problèmes et sans erreurs.

Merci beaucoup !


Fichier(s) joint(s) :
Pour accéder aux fichiers vous devez vous inscrire.

Hors ligne

 

#2 Thu 19 November 2020 10:59

xav
Membre
Date d'inscription: 27 Oct 2005
Messages: 268

Re: Connexions des attributs qui sautent à chaque sauvegarde du projet

Bonjour,
vos connexion sont à priori faites manuellement.
Ceci peut s'avérer assez dangereux et amener des problèmes comme ceux que vous avez.
Une astuce consiste à remplacer ces connexion faites manuellement par un attributemanger qui renommera les attributs (et donc plus de soucis de connexion).
Pour faire cela, il vous suffit, une fois que les connexion sont faites, de faire un clic droit sur le lien entre le transformer et la destination et de choisir dans le menu Remplacer les liens avec AttributeManager. (comme sur la capturejointe).
En espérant que cela résolve votre problème.


Xavier Lang
Information géographique et observatoire - DSI Communautaire
Cap Atlantique

Hors ligne

 

#3 Thu 19 November 2020 11:00

xav
Membre
Date d'inscription: 27 Oct 2005
Messages: 268

Re: Connexions des attributs qui sautent à chaque sauvegarde du projet

Bonjour,
vos connexion sont à priori faites manuellement.
Ceci peut s'avérer assez dangereux et amener des problèmes comme ceux que vous avez.
Une astuce consiste à remplacer ces connexion faites manuellement par un attributemanger qui renommera les attributs (et donc plus de soucis de connexion).
Pour faire cela, il vous suffit, une fois que les connexion sont faites, de faire un clic droit sur le lien entre le transformer et la destination et de choisir dans le menu Remplacer les liens avec AttributeManager. (comme sur la capturejointe).
En espérant que cela résolve votre problème.


Xavier Lang
Information géographique et observatoire - DSI Communautaire
Cap Atlantique

Hors ligne

 

#4 Thu 19 November 2020 17:10

Tan85
Membre
Date d'inscription: 20 Sep 2019
Messages: 2

Re: Connexions des attributs qui sautent à chaque sauvegarde du projet

Merci beaucoup pour le conseil, ça marche maintenant !
Dans ma version de FME ça s'appelle AttributeCopier et pas AttributeManager.

Merci, bonne soirée

Tancredi Pozzana
Valence Romans Agglo

Hors ligne

 

Pied de page des forums

Powered by FluxBB

Partagez  |