Nous utilisons des cookies pour vous garantir la meilleure expérience sur notre site. Si vous continuez à utiliser ce dernier, nous considèrerons que vous acceptez l'utilisation des cookies. J'ai compris ! ou En savoir plus !.
banniere

Le portail francophone de la géomatique


Toujours pas inscrit ? Mot de passe oublié ?
Nom d'utilisateur    Mot de passe              Toujours pas inscrit ?   Mot de passe oublié ?

#1 Wed 28 April 2021 20:46

franyam
Membre
Lieu: Burkina Faso
Date d'inscription: 28 Oct 2014
Messages: 37

QGIS Server: Comment installer une version anterieure ?

Bonjour à tous,

Il ya un an de cela , dans le cadre d'un projet Lizmap j'avais téléchargé et installé la version 3.10 de QGIS Server sous Windows dont le fichier exécutable est osgeo4w-setup-x86_64.exe.

Cette année j'ai repris le même fichier exécutable osgeo4w-setup-x86_64.exe et je l'ai exécuté pour l'installer. Je constate que la version a changé , elle est passé de 3.10 à 3.16 (voir fichier joint)

Alors que c'est le même fichier que j'avais installé il y a un an et qui avait la version 3.10. Maintenant je cherche à présent a installé la version précédente qui était 3.10 je n'y arrive plus. 
Que faire ?  Merci d'avance pour vos réponse


Fichier(s) joint(s) :
Pour accéder aux fichiers vous devez vous inscrire.

Hors ligne

 

#2 Thu 29 April 2021 00:28

Benoit D
Membre
Date d'inscription: 17 Jul 2018
Messages: 19

Re: QGIS Server: Comment installer une version anterieure ?

Bonjour, osgeo4w-setup-x86_64.exe est un installateur qui vous propose la dernière version en cours ou la dernière version support long comme le rappelle la page https://www.qgis.org/fr/site/forusers/download.html :

Dans l'installateur, choisissez Desktop Express Install et sélectionnez QGIS pour installer la dernière version.
Pour obtenir la version long terme (qui peut être différente de la dernière version) choisissez l'Installateur pour utilisateurs experts et sélectionnez qgis-ltr-full
Pour obtenir la version des tout derniers développements choisissez l'Installateur pour utilisateurs experts et sélectionnez qgis-full-dev


Pour installer d’anciennes versions rendez-vous sur https://qgis.org/downloads/

Hors ligne

 

#3 Thu 29 April 2021 01:41

franyam
Membre
Lieu: Burkina Faso
Date d'inscription: 28 Oct 2014
Messages: 37

Re: QGIS Server: Comment installer une version anterieure ?

Bonjour Benoit D.

Merci d'avoir pris de votre temps pour répondre à ma préoccupation.
" Pour installer d’anciennes versions rendez-vous sur https://qgis.org/downloads/" En fait sur cette adresse que vous avez écrite , il n'ya pas d'anciennes version de QGIS Server. Il n' y a que d'anciennes version de QGIS Desktop. Merci pour l'intéret.

Hors ligne

 

#4 Mon 03 May 2021 12:07

SANTANNA
Moderateur
Lieu: Angers
Date d'inscription: 18 Jan 2008
Messages: 2815

Re: QGIS Server: Comment installer une version anterieure ?

Bonjour,

franyam a écrit:

Alors que c'est le même fichier que j'avais installé il y a un an et qui avait la version 3.10. Maintenant je cherche à présent a installé la version précédente qui était 3.10 je n'y arrive plus.


osgeo4w est une cible mouvante. C'est un moyen rapide d'accéder aux versions actuelles des dépôts de QGIS et dans le dépôt LTR, la 3.16 a remplacé la 3.10. Parfois, en cliquant sur le numéro de version (de mémoire), il propose la ou les versions précédemment installées mais je ne sais pas si ça marche dans ce cas-ci (et j'imagine que ce n'est pas pour le même poste).
Comme suggéré dans le ticket github, ce serait bien de poser la question à la communauté, sur la mailing-list. C'est étrange effectivement qu'on n'offre pas la possibilité de réinstaller une ancienne version de QGIS Server...

Hors ligne

 

#5 Mon 03 May 2021 19:38

franyam
Membre
Lieu: Burkina Faso
Date d'inscription: 28 Oct 2014
Messages: 37

Re: QGIS Server: Comment installer une version anterieure ?

Bonjour SANTANNA,

Explication très claire ! merci. Vous avez apporté les éléments de réponses clairs à ma préoccupation. En résumé, d'après mes fouilles également je me rend compte que QGIS Server se met immédiatement à jour à chaque installation. Puisque dans l'une des options en installation , il se connecte aux ressources du site osgeo4w.org.

Pour mon projet webmapping avec lizmap, j'ai retrouvé un fichier qui donne les compatibilité entre les version QGIS Server et llizmap. Ainsi j'ai essayé lizmap 3.2.13 et lizmap web client 3.3.12 avec QGIS Server 3.16.6 (version actuelle) et évidemment QGIS Desktop 3.16.6 et je peux vous assurer que ç marche à merveille !

merci à tous ceux qui ont contribué à me mettre sur le chemin

Hors ligne

 

Pied de page des forums

Powered by FluxBB

Partagez  |