Nous utilisons des cookies pour vous garantir la meilleure expérience sur notre site. Si vous continuez à utiliser ce dernier, nous considèrerons que vous acceptez l'utilisation des cookies. J'ai compris ! ou En savoir plus !.
banniere

Le portail francophone de la géomatique


Toujours pas inscrit ? Mot de passe oublié ?
Nom d'utilisateur    Mot de passe              Toujours pas inscrit ?   Mot de passe oublié ?

Annonce


	

Les GeoDataDays 2021 auront lieu les 15 et 16 septembre 2021 à Grenoble

 

Evénement national de référence et indépendant de la géographie numérique en France, cette rencontre est organisée par l'Afigéo et DécryptaGéo, en partenariat avec une plateforme régionale d'information géographique et des collectivités territoriales associées

Les inscriptions sont ouvertes et le programme disponible !

#1 Thu 10 June 2021 15:33

Raf
Membre
Date d'inscription: 25 Oct 2019
Messages: 11

QGIS/Atlas: utilisation d'une image bloque sur SVG

Bonjour à tous!

J'ai un problème dans la génération de mon atlas : Je voudrais créer une série de fiche en fonction d'une couche avec un champ qui contient un chemin d'accès vers une image.
Je voudrais afficher cette image dans mes fiches en utilisant le contenu du champ comme chemin d'accès vers l'image, mais celle-ci est bloquée sur le format "SVG" et impossible de choisir le format "image raster". Du coup, l'image ne s'affiche pas.

Savez vous comment résoudre ce problème?

Merci d'avance!!

Hors ligne

 

#2 Thu 10 June 2021 17:23

michel56
Membre
Lieu: Lorient
Date d'inscription: 14 Jul 2012
Messages: 440

Re: QGIS/Atlas: utilisation d'une image bloque sur SVG

Bonjour,


J'ai eu ce problème et la raison était l'absence des images à l'endroit indiqué.


Opérateur cartographique & DAO & PHP.

Hors ligne

 

#3 Sat 12 June 2021 14:02

Raf
Membre
Date d'inscription: 25 Oct 2019
Messages: 11

Re: QGIS/Atlas: utilisation d'une image bloque sur SVG

Merci pour votre réponse, mais ca n'est pas ca... J'ai bien toutes mes images à l'endroit indiqué...

Hors ligne

 

#4 Aujourd'hui 08:12

Raf
Membre
Date d'inscription: 25 Oct 2019
Messages: 11

Re: QGIS/Atlas: utilisation d'une image bloque sur SVG

Re bonjour. J'ai trouvé la solution :
En fait le composeur d'impression ne reconnaît pas les chemins relatifs (ce qui était mon cas. Le champs contenant le chemin de l'image était un champ relatif au projet)
Pour pallier à ce problème, il faut aller sur les propriété de l'objet > définir une valeur par une expression > rentrer l'expression suivante :

concat(@project_folder, '/', "champ_image")

de cette façon, on traduit le chemin relatif en chemin absolu

Hors ligne

 

Pied de page des forums

Powered by FluxBB

Partagez  |