Nous utilisons des cookies pour vous garantir la meilleure expérience sur notre site. Si vous continuez à utiliser ce dernier, nous considèrerons que vous acceptez l'utilisation des cookies. J'ai compris ! ou En savoir plus !.
Nom d'utilisateur    Mot de passe              Toujours pas inscrit ?   Mot de passe oublié ?

Annonce

Suite à un problème sur notre serveur une intervention a été planifiée ce  matin. La coupure, qui ne devait pas exéder 5 mn, a duré plus longtemps que prévu. L'intervention consistait à l'augmentation de l'espace disque (GeoRezo prend un peu plus de place en viellissant). Malheureusement, le serveur se faisant vieux, quelques soucis ont eu lieu.

Nous avons procédé à un gros nettoyage d'automne : augmentation de l'espace disque, mise à jour des certificats SSL pour l'utilisation des  urls en https, upgrade d'Apache et autres outils nécessaire au bon fonctionnement.

Notre volonté à long terme est de consolider la plateforme GeoRezo et nous accueillons toutes personnes intéressées pour nous aider (technologies utilisées : drupal, docker, MySQL, git, etc.) Si vous désirez contribuer à un projet dynamique et apprendre de nouvelles choses, contactez nous !

L'équipe GeoRezo

#1 jeu. 10 mars 2016 23:47

Olivier83_48
Membre
Date d'inscription: 16 janv. 2016
Messages: 31

QGIS 2.14 (Ubuntu 10.15 Linux) : Support ECW ?

Bonsoir à tous,

J'ai un problème devant lequel je mouline depuis des heures sur la toile...

Après avoir perdu des heures à chercher à comprendre, je rend les armes et demande votre soutien.

Malgré la lecture de http://georezo.net/wiki/main/logiciels/ … stallation , je suis dans l'incapacité totale d'utiliser un raster en ECW sous QGIS 2.14 sous l'OS Ubuntu 15.10.

J'applique la recette du chapitre "Pour Ubuntu 14.04 et dérivé (Mint 17)" et arrive à installer libgdal-ecw-src et la librairie libecwj2.

Mais, échec total !

La commande

Code:

$ gdalinfo –formats | grep clearECW

donne :

Code:

ERROR 4: `–formats' does not exist in the file system,
and is not recognised as a supported dataset name.

gdalinfo failed - unable to open '–formats'.

Ne sachant trop si ce chapitre est caduque, je tente le suivant "UPDATE QGIS > 2.6.1 sous UBUNTU 14.04.X et dérivé Mint (17.X)"

Echec total dès la première ligne "en root, créer le répertoire /usr/lib/gdalplugins/1.11" car :

Code:

mkdir: impossible de créer le répertoire «/usr/lib/gdalplugins/1.11»: Aucun fichier ou dossier de ce type

De toute façon je ne sens pas trop cette dernière partie qui mise sous un "coup de bluf"...

Est-il donc impossible de lire les ecw sous Linux (Ubuntu) ?

Si vous avez réussi ce tour de force ou avez un carton de dolipranes à m'expédier, merci !

Hors ligne

 

#2 ven. 11 mars 2016 09:55

Julie P
Membre
Lieu: Pessac
Date d'inscription: 4 oct. 2006
Messages: 105
Site web

Re: QGIS 2.14 (Ubuntu 10.15 Linux) : Support ECW ?

Bonjour,

En fait la commande pour vérifier si gdal prend en charge l'ECW est la suivante :

Code:

gdalinfo --formats | grep clearECW

(Il y a 2 tirets devant formats, le wiki les a convertis automatiquement en un seul tiret. Du coup je ne sais pas comment faire la modification dans le wiki ?)

Chez moi (Ubuntu 14.04, QGIS 2.14) ça fonctionne, j'avais suivi les instructions ici : http://gis.stackexchange.com/questions/ … 088#102088
Mais ce sont peut-être les mêmes que sur le wiki du georezo, je n'ai pas vérifié !

Hors ligne

 

#3 ven. 11 mars 2016 15:13

Olivier83_48
Membre
Date d'inscription: 16 janv. 2016
Messages: 31

Re: QGIS 2.14 (Ubuntu 10.15 Linux) : Support ECW ?

Salut,

J'ai essayé avec la formule corrigée, mais ça ne donne rien...

Hors ligne

 

#4 ven. 11 mars 2016 17:12

Lsam
Membre
Date d'inscription: 27 nov. 2013
Messages: 98

Re: QGIS 2.14 (Ubuntu 10.15 Linux) : Support ECW ?

Bonjour,

Donc ta version de GDAL ne prend pas en charge le format ECW. Normal puisque l'installation a échoué...

Avant de faire tout et n'importe quoi, quelle est ta version de gdal et des paquets liés ? Copie nous le résultat de cette commande rapide :

Code:

dpkg-query -W -f='${binary:Package} | ${Version} | ${Architecture}\n' '*gdal*'

Hors ligne

 

#5 ven. 11 mars 2016 18:46

Olivier83_48
Membre
Date d'inscription: 16 janv. 2016
Messages: 31

Re: QGIS 2.14 (Ubuntu 10.15 Linux) : Support ECW ?

Bonsoir,

Voici le résultat de la commande :

Code:

gdal-bin | 1.11.2+dfsg-3ubuntu3 | amd64
libgdal-dev | 1.11.2+dfsg-3ubuntu3 | amd64
libgdal-doc |  | 
libgdal-ecw-src | 1.10.0-1~raring4 | all
libgdal.so.1-1.11.2 |  | 
libgdal1 |  | 
libgdal1-1.6.0 |  | 
libgdal1-dev |  | 
libgdal1h |  | 
libgdal1i | 1.11.2+dfsg-3ubuntu3 | amd64
python-gdal | 1.11.2+dfsg-3ubuntu3 | amd64
python2.7-gdal |  |

Hors ligne

 

#6 lun. 14 mars 2016 22:10

Olivier83_48
Membre
Date d'inscription: 16 janv. 2016
Messages: 31

Re: QGIS 2.14 (Ubuntu 10.15 Linux) : Support ECW ?

Bonsoir à tous,

Je suis toujours bloqué devant cette histoire bien embarrassante d'ecw inaccessible sous Linux. Si j'ai bien compris, j'ai une version de GDAL (1.11) incompatible avec l'ECW, et la manip (le "coup de bluff", cf. 1er post de ce fil) expliquée dans le wiki de GeoRezo ne fonctionne pas car le dossier indiqué /usr/lib/gdalplugins dans lequel créer un répertoire "1.11" n'existe tout simplement pas. Donc, cette manip semble caduque sous Kubuntu 15.10.

Que puis-je faire alors ?

La solution est-elle dans une conversion ecw vers le format Geotif ?

Il y a bien des personnes, ici, qui utilisent Ubuntu 15.10 et ont besoin de travailler avec des ecw sous QGIS ? Non ? Comment avez-vous résolu ce problème ?

Hors ligne

 

#7 mar. 15 mars 2016 09:09

Lsam
Membre
Date d'inscription: 27 nov. 2013
Messages: 98

Re: QGIS 2.14 (Ubuntu 10.15 Linux) : Support ECW ?

Bonjour,

C'est vraiment un problème ces formats propriétaires...

Il va te falloir récupérer les sources de libecw et les compiler : c'est ça le plus pénible car il faut trouver les bonnes sources... Puis il va falloir compiler gdal avec la prise en charge de la libecw : ça c'est plus simple.

Si tu es tenté par l'expérience, je peux t'assister, sans garantie de résultat malheureusement.

Hors ligne

 

#8 mar. 15 mars 2016 11:09

ThomasG
Membre
Lieu: Nantes
Date d'inscription: 9 sept. 2005
Messages: 790
Site web

Re: QGIS 2.14 (Ubuntu 10.15 Linux) : Support ECW ?

Bonjour,

Il y a bien des personnes, ici, qui utilisent Ubuntu 15.10 et ont besoin de travailler avec des ecw sous QGIS ?

Pour information, personne en entreprise voulant de la stabilité n'utilise une version autre qu'une version Ubuntu LTS (Long Term Support) 14.04 ou 16.04 sous peu, pour éviter vos écueils justement. De ce fait, des personnes ayant une version d'Ubuntu 15.10 sont très minoritaires.

Pour votre problème de répertoire, même si c'est clairement du contournement très très moche, créez le répertoire avant vos tests avec

Code:

sudo mkdir -p /usr/lib/gdalplugins/1.11

Cordialement


Thomas

Hors ligne

 

#9 mar. 15 mars 2016 12:15

dominique.lys
Membre
Date d'inscription: 5 oct. 2006
Messages: 317
Site web

Re: QGIS 2.14 (Ubuntu 10.15 Linux) : Support ECW ?

Salut,


Malheureusement aujourd'hui la seule solution est de compiler soit-même GDAL avec libECW.

Soit on récupère une version récente du SDK sur le site d'Hexagon (ex ERDAS) car oui existe bien des versions récentes du SDK ECW pour linux mais la licence est moins permissive que ce que proposait ER Mapper à l'époque.

L'autre option est donc de récupérer une ancienne version (libecwj2-3.3) que l'on trouve facilement sur le web, le problème étant que cette version est ancienne et buggée, il faudra donc appliquer quelques patchs avant de lancer la compilation.

Tout est détaillé ici:

https://trac.osgeo.org/gdal/wiki/ECW


Moralité, quand on fait le choix de linux il faut sérieusement se demander comment s'affranchir de l'ECW. Le geotiff offre des possibilités qui permettent  vraiment de s’approcher des performances de l'ECW.

http://blog.cleverelephant.ca/2015/02/g … mmies.html

Hors ligne

 

#10 mar. 15 mars 2016 15:21

labebobo
Membre
Date d'inscription: 14 déc. 2011
Messages: 10

Re: QGIS 2.14 (Ubuntu 10.15 Linux) : Support ECW ?

Salut,
hier justement, je me suis amusé avec du ECW sur ubuntu.
J'ai choisi une solution plus radicale.

J'ai créé un container docker pré configuré pour de l'ECW pour y modifier mes données en TIF.

Voilà, cela m'a évité l'ennui de l'installation.

Si cette piste t'intéresse,
voici un guide, n'hésites pas à donner des retours. il y a plusieurs pistes d'amélioration.

http://www.gis-blog.fr/2016/03/14/trava … ec-docker/

Bonne journée

Quentin

Hors ligne

 

#11 mar. 15 mars 2016 18:48

Olivier83_48
Membre
Date d'inscription: 16 janv. 2016
Messages: 31

Re: QGIS 2.14 (Ubuntu 10.15 Linux) : Support ECW ?

labebobo a écrit:

Salut,
hier justement, je me suis amusé avec du ECW sur ubuntu.
J'ai choisi une solution plus radicale.

J'ai créé un container docker pré configuré pour de l'ECW pour y modifier mes données en TIF.

Voilà, cela m'a évité l'ennui de l'installation.

Si cette piste t'intéresse,
voici un guide, n'hésites pas à donner des retours. il y a plusieurs pistes d'amélioration.

http://www.gis-blog.fr/2016/03/14/trava … ec-docker/

Bonne journée

Quentin

Bonjour Quentin,

Oui, ta piste m'intéresse, mais j'échoue dès l'étape "docker".

J'installe docker avec synaptic, mais ensuite la commande "docker run -ti --rm -v $(pwd):/data klokantech/gdal /bin/bash" échoue et me dit que docker.io n'est pas installé...

J'installe avec synaptic docker.io, mais la commande docker run -ti --rm -v $(pwd):/data klokantech/gdal /bin/bash échoue de nouveau :

Code:

FATA[0000] Post http://%2Fvar%2Frun%2Fdocker.sock/v1.18/containers/create: dial unix /var/run/docker.sock: connect: permission denied. Are you trying to connect to a TLS-enabled daemon without TLS?

Je vais devenir chèvre...

Hors ligne

 

#12 jeu. 17 mars 2016 11:26

labebobo
Membre
Date d'inscription: 14 déc. 2011
Messages: 10

Re: QGIS 2.14 (Ubuntu 10.15 Linux) : Support ECW ?

Bonjour,
En effet, je ne me suis pas étalé sur l'étape docker, j'aurais pu en faire un peu plus.

donc la version dans les dépôts n'est pas à jour.
il est conseillé d'insaller docker via leurs propres dépôts via les commande suivantes dans le terminal.
la première installe curl et la seconde ajoute de dépôt à ubuntu et réalise l'installation. Cela devrait te demander un droit d'administrateur dans le script.

Code:

$ sudo apt-get update
sudo apt-get update
sudo apt-get install curl 
curl -fsSL https://get.docker.com/ | sh

Tu as une version anglaise
https://docs.docker.com/linux/step_one/

Préalablement, je te conseillerai de désinstaller ce qui relève de docker sur ton pc
à l'aide de la commande

Code:

sudo apt-get autoremove docker.io docker

Voilà, n'hésites pas, je vais compléter mon guide à cette occasion.
Bonne journée.
Quentin

Dernière modification par labebobo (jeu. 17 mars 2016 11:31)

Hors ligne

 

#13 jeu. 17 mars 2016 21:24

Olivier83_48
Membre
Date d'inscription: 16 janv. 2016
Messages: 31

Re: QGIS 2.14 (Ubuntu 10.15 Linux) : Support ECW ?

Merci Quentin, je testerai ça ce week-end, car là où je suis je suis embêté par un proxy qui, je pense, m'empêche d'installer des paquets.

Je tiendrai au courant des manips bientôt.

Hors ligne

 

#14 lun. 21 mars 2016 00:18

Olivier83_48
Membre
Date d'inscription: 16 janv. 2016
Messages: 31

Re: QGIS 2.14 (Ubuntu 10.15 Linux) : Support ECW ?

Bonjour,

J'ai tenté les manips avec docker installé à partir de ses propres dépôts.

J'ai suivi toutes les étapes, mais rien n'y fait, ça ne marche pas.

J'ai produit un fichier tif de 2,1 Go à partir d'un fichier ecw de 2,9 Go, mais le fichier tif est illisible par QGIS (et je suis bien dans le bon système de projection).

Dernière modification par Olivier83_48 (lun. 21 mars 2016 08:09)

Hors ligne

 

#15 mar. 22 mars 2016 23:38

Olivier83_48
Membre
Date d'inscription: 16 janv. 2016
Messages: 31

Re: QGIS 2.14 (Ubuntu 10.15 Linux) : Support ECW ?

Je suis toujours en rade devant ce problème de fichiers ECW.

Hors ligne

 

#16 ven. 25 mars 2016 08:39

Olivier83_48
Membre
Date d'inscription: 16 janv. 2016
Messages: 31

Re: QGIS 2.14 (Ubuntu 10.15 Linux) : Support ECW ?

Bonjour,

Je suis toujours en plan depuis deux semaines devant mon fichier ecw inaccessible.

@labebobo : que faire quand le fichier généré par ta solution a échoué ?

Hors ligne

 

#17 ven. 25 mars 2016 22:32

Olivier83_48
Membre
Date d'inscription: 16 janv. 2016
Messages: 31

Re: QGIS 2.14 (Ubuntu 10.15 Linux) : Support ECW ?

@labebobo : que faire quand le fichier généré par ta solution a échoué ?

Si tu as le temps de re-jeter un oeil à ce problème.

Hors ligne

 

#18 dim. 27 mars 2016 20:01

labebobo
Membre
Date d'inscription: 14 déc. 2011
Messages: 10

Re: QGIS 2.14 (Ubuntu 10.15 Linux) : Support ECW ?

Bonjour,
je n'ai pas eu trop de disponibilité pour reprendre la question.

donc, pour avancer, on peut imaginer plusieurs manières de résoudre le problème:
- tu puisses indiquer toutes les commandes que tu as rentré et les messages d'erreur (si tu en as) expliquant pourquoi le fichier est illisible
- tu puisse transférer le document à partir duquel tu travailles (un bout) pour que je puisse faire un test de mon côté savoir si d'autres choses ont à faire.
- je fasses un guide vidéo des différentes étapes du travail (si tu considère que cela peut t'aider à travailler sur la question)

Hors ligne

 

#19 jeu. 31 mars 2016 21:56

Olivier83_48
Membre
Date d'inscription: 16 janv. 2016
Messages: 31

Re: QGIS 2.14 (Ubuntu 10.15 Linux) : Support ECW ?

Salut et merci pour ton intérêt, mais je laisse tomber, trop compliqué et trop de manips pour moi, surtout qu'à la prochaîne version d'Ubuntu, il y a 99% de chances pour que la solution trouvée devienne caduque.

J'ai trouvé une autre solution en laissant tomber mon fichier ecw au profit d'un accès aux flux wms de l'IGN.

J'aime bien Linux et sa philosophie, mais, plonger les mains dans le cambouis pendant des heures interminables dans des manoeuvres tortueuses, non merci, je préfère me consacrer à ce qui m'intéresse vraiment.

Hors ligne

 

#20 ven. 01 avril 2016 13:04

labebobo
Membre
Date d'inscription: 14 déc. 2011
Messages: 10

Re: QGIS 2.14 (Ubuntu 10.15 Linux) : Support ECW ?

Bonjour,
je comprends tout à fait ton souhait de te délaisser de ce problème. Quand le moyen devient une fin, on s'épuise et on pourrait en oublier pourquoi nous faisions cela.
L'important est que tu puisse avoir trouvé une solution. Le fait d'utiliser les services web me semble aussi être la solution la plus fiable.

La question des pilotes ECW dans linux est une question difficile à trancher pour moi, j'ai l'impression qu'en affinant les réglages on peut atteindre une qualité tout à fait acceptable.

Ici une ressource soulignée par Michaël Douchin en réponse à l'article: https://t.co/pYQoDzIFnF


Pour resituer malgré tout selon mois, ce qui est en jeu, ce n'est pas l'univers linux mais un problème de licence et de "codecs" associés à ces produits. le constat est le même: c'est chiant mais la raison diffère.

Bonne journée
Quentin

Hors ligne

 

#21 sam. 02 avril 2016 19:20

Olivier83_48
Membre
Date d'inscription: 16 janv. 2016
Messages: 31

Re: QGIS 2.14 (Ubuntu 10.15 Linux) : Support ECW ?

labebobo a écrit:

Pour resituer malgré tout selon mois, ce qui est en jeu, ce n'est pas l'univers linux mais un problème de licence et de "codecs" associés à ces produits. le constat est le même: c'est chiant mais la raison diffère.

Bonne journée
Quentin

Oui en effet c'est bien là le problème.

Hors ligne

 

Pied de page des forums

Powered by FluxBB

Partagez  |