Nous utilisons des cookies pour vous garantir la meilleure expérience sur notre site. Si vous continuez à utiliser ce dernier, nous considèrerons que vous acceptez l'utilisation des cookies. J'ai compris ! ou En savoir plus !.
Nom d'utilisateur    Mot de passe              Toujours pas inscrit ?   Mot de passe oublié ?

Annonce

GeoRezo est partenaire média de la Conférence Francophone SIG 2017 organisée par ESRI.

Les bénévoles de l'association seront présents les 11 et 12 Octobre aux Docks de Paris.

Le programme est riche, mais vous trouverez bien un  moment pour venir faire une pause au stand GeoRezo, et rencontrer les animateurs du portail francophone de la géomatique.

Nous serons à votre écoute pour partager avec vous notre passion pour l’animation du portail GeoRezo.

L'équipe GeoRezo

#1 jeu. 03 novembre 2016 11:57

RemyPy
Membre
Date d'inscription: 1 déc. 2012
Messages: 1

[OTB] - Classification SVM

Bonjour,

je souhaite réaliser une classification pixel SVM avec OTB.
Pour cela j'utilise l'application otbcli_TrainImagesClassifier

J'utilise OTB 5.4.0. J'obtiens le message d'erreur suivant :

ERROR: option -classifier.libsvm.k does not exist in the application.
This is the TrainImagesClassifier application, version 5.4.0
Train a classifier from multiple pairs of images and training vector data.
Complete documentation: http://www.orfeo-toolbox.org/Applicatio … ifier.html

Je me demande donc s'il existe encore un algorithme de classif SVM dans la version 5.4.O d'OTB. D'après le cookbook 5.4.0, il semblerait que oui puisque l'exemple pris pour le chapitre de la classification pixel est une classification SVM. De plus le lien vers lequel renvoie l'erreur indique également l'existence d'un paramètre libsvm (http://www.orfeo-toolbox.org/Applicatio … ifier.html
).

Seulement en appelant la documentation de l'outil directement dans le Shell OSGeo4W j'obtiens ceci concernant le paramètre -classifier
Version 5.4.0 d'OTB
-classifier                     Classifier to use for the training [boost/dt/gbt/ann/bayes/rf/knn] (mandatory, default value is boost)

Version 5.0.0 d'OTB
-classifier                     Classifier to use for the training [libsvm/svm/boost/dt/gbt/ann/bayes/rf/knn] (mandatory, default value is libsvm)

Il n'y a plus libsvm/svm comme paramètres proposés dans la version 5.4.0. Est-ce que ça signifie qu'il n'est plus possible de faire une classification SVM depuis OTB 5.4.0 ?

Merci d'avance, Pierre-Yves

Hors ligne

 

Pied de page des forums

Powered by FluxBB

Partagez  |