Nous utilisons des cookies pour vous garantir la meilleure expérience sur notre site. Si vous continuez à utiliser ce dernier, nous considèrerons que vous acceptez l'utilisation des cookies. J'ai compris ! ou En savoir plus !.
Nom d'utilisateur    Mot de passe              Toujours pas inscrit ?   Mot de passe oublié ?

Annonce

Suite à un problème sur notre serveur une intervention a été planifiée ce  matin. La coupure, qui ne devait pas exéder 5 mn, a duré plus longtemps que prévu. L'intervention consistait à l'augmentation de l'espace disque (GeoRezo prend un peu plus de place en viellissant). Malheureusement, le serveur se faisant vieux, quelques soucis ont eu lieu.

Nous avons procédé à un gros nettoyage d'automne : augmentation de l'espace disque, mise à jour des certificats SSL pour l'utilisation des  urls en https, upgrade d'Apache et autres outils nécessaire au bon fonctionnement.

Notre volonté à long terme est de consolider la plateforme GeoRezo et nous accueillons toutes personnes intéressées pour nous aider (technologies utilisées : drupal, docker, MySQL, git, etc.) Si vous désirez contribuer à un projet dynamique et apprendre de nouvelles choses, contactez nous !

L'équipe GeoRezo

#1 sam. 26 novembre 2016 15:33

digitex9
Membre
Date d'inscription: 26 nov. 2016
Messages: 3

PostGis : Shapefile import failed ?

Bonjour,

J'ai une couche codé en UTF-8 que j'ai créé sur QGIS, mais je n'arrive pas à l'ouvrir sur PostGIS (PgAdmin III):

J'obtiens ce message :

https://i.imgsafe.org/99a7c9bafd.png

J'ai bien cherché auparavant, mais je n'ai pas trouvé de sujet similaire.

Bien cordialement,

Hors ligne

 

#2 sam. 26 novembre 2016 18:11

Lsam
Membre
Date d'inscription: 27 nov. 2013
Messages: 98

Re: PostGis : Shapefile import failed ?

Bonjour,

Ça ne solutionnera pas directement ton problème, mais si l'on veut importer par exemple une couche SHP encodée en Latin-1 (ou  ISO 8859-1 dont dérive Windows-1252 ou  ISO 8859-15) dans PostGIS avec GDAL, sur un OS en UTF-8, il faut faire précéder la commande par PGCLIENTENCODING=LATIN1.
Ce qui donne en ligne de commande par exemple :

Code:

PGCLIENTENCODING=LATIN1 ogr2ogr -skipfailures -update -overwrite -progress -f PostgreSQL -a_srs "EPSG:ZZZZ" -overwrite PG:"host=domain.tld user=XXXXXX password=XXXXXX dbname=YYYY

Regarde donc dans les options s'il n'y a pas quelquechose lié au codage de caractères pour forcer l'UTF-8.

Hors ligne

 

#3 sam. 26 novembre 2016 19:04

digitex9
Membre
Date d'inscription: 26 nov. 2016
Messages: 3

Re: PostGis : Shapefile import failed ?

Voici Les options que je mets:
https://i.imgsafe.org/9cdda271dd.png

Je viens de trouver une solution, mais je ne comprends pas pourquoi :

Quand je refais la même manipulation ( Ouvrir PostGIS et importer le fichier SHP ) sur la base de donnée exemple de Postgist qui a été formée à l'installation : "postgis_23_sample" , ça marche !

Mais quand il s'agit des BDD que j'ai ajouté moi même , ça me donne ce problème :
https://i.imgsafe.org/9ce56d5901.png

Faut-il faire quelque chose spécifique pour que la BDD accepte les fichiers SHP ?

Bien cordialement,

Hors ligne

 

#4 sam. 26 novembre 2016 20:06

Lsam
Membre
Date d'inscription: 27 nov. 2013
Messages: 98

Re: PostGis : Shapefile import failed ?

Essai 'UTF8' au lieu de 'UTF-8' dans les options.

Sinon si ça fonctionne avec d'autres bases, c'est que celles-ci sont encodées dans le système de codage de ton OS.

Hors ligne

 

#5 sam. 26 novembre 2016 21:17

digitex9
Membre
Date d'inscription: 26 nov. 2016
Messages: 3

Re: PostGis : Shapefile import failed ?

J'enregistre la base de donnée à nouveau en spécifiant l'encodage, j'ai refait l'essaie avec l'encodage LATIN1:

http://i.imgsafe.org/9ecd0ad33f.png

J'obtiens la même erreur avec 'LATIN1' ou même 'latin1' :

http://i.imgsafe.org/9ed9d112ee.png

Hors ligne

 

Pied de page des forums

Powered by FluxBB

Partagez  |