Nous utilisons des cookies pour vous garantir la meilleure expérience sur notre site. Si vous continuez à utiliser ce dernier, nous considèrerons que vous acceptez l'utilisation des cookies. J'ai compris ! ou En savoir plus !.
Nom d'utilisateur    Mot de passe              Toujours pas inscrit ?   Mot de passe oublié ?

Annonce

GeoRezo est partenaire média de la Conférence Francophone SIG 2017 organisée par ESRI.

Les bénévoles de l'association seront présents les 11 et 12 Octobre aux Docks de Paris.

Le programme est riche, mais vous trouverez bien un  moment pour venir faire une pause au stand GeoRezo, et rencontrer les animateurs du portail francophone de la géomatique.

Nous serons à votre écoute pour partager avec vous notre passion pour l’animation du portail GeoRezo.

L'équipe GeoRezo

#1 lun. 13 mars 2017 21:04

drfrangipane
Membre
Date d'inscription: 27 juin 2013
Messages: 5

Clip grid with polygon 'NoneType' object has no attribute 'crs' Seelog

Dear all,
"Clip grid with polygon" with a lower resolution dem file,
j'utilise le modeleur qgis. quand j'execute le modèle et ses  geotreatments: "Clip grid with polygon"  sur un fichier MNT à 250 metres, tout se passe bien, apparemment, j'obtiens les résultats attendus.

2017-03-13T17:13:43 0 Commandes d'exécution SAGA
io_gdal 0 -TRANSFORM -INTERPOL 0 -GRIDS "C:\Users\aquesnel\AppData\Local\Temp\processingf5dc5fb6cb7947ee8284b056942375ff\99c223ed05e24d779d2fde239cfcec3b\FRANCEMNT250L93.sgrd" -FILES "C:/Users/aquesnel/.qgis2/processing/entree/MNT250_L93_FRANCE.TIF"
shapes_grid "Clip Grid with Polygon" -INPUT "C:\Users\aquesnel\AppData\Local\Temp\processingf5dc5fb6cb7947ee8284b056942375ff\99c223ed05e24d779d2fde239cfcec3b\FRANCEMNT250L93.sgrd" -POLYGONS "C:\Users\aquesnel\AppData\Local\Temp\processingf5dc5fb6cb7947ee8284b056942375ff\d65dc3598bb64c76804f4561543f5f0b\outputALGGRASS7V.BUFFER.DISTANCE1.shp" -OUTPUT "C:\Users\aquesnel\AppData\Local\Temp\processingf5dc5fb6cb7947ee8284b056942375ff\3ccff3d96dda44e2bfe36232a5c4b971\OUTPUT.sdat"


mais j'obtiens avec le meme modèle et algorithme de la librairie saga "Clip grid with polygon"  cette fois sur un MNT france à 25metres (high resolution) un message d'erreurs

Clip Grid with Polygon: could not initialize data objects
Error: Grid file could not be opened.
Error: executing tool [Clip Grid with Polygon]
F:\PROGRA~3\qgis_2.18\bin>exit
Converting outputs
Echoué
Erreur lors de l'exécution de l'algorithme Clip grid with polygon 'NoneType' object has no attribute 'crs' See log for more details
2017-03-13T17:26:27 2 Uncaught error while executing algorithm
Traceback (most recent call last):
File "F:/PROGRA~3/qgis_2.18/apps/qgis/./python/plugins\processing\core\GeoAlgorithm.py", line 205, in execute
self.convertUnsupportedFormats(progress)
File "F:/PROGRA~3/qgis_2.18/apps/qgis/./python/plugins\processing\core\GeoAlgorithm.py", line 296, in convertUnsupportedFormats
crsid = layer.crs().authid()
AttributeError: 'NoneType' object has no attribute 'crs'
2017-03-13T17:26:27 2 Erreur lors de l'exécution de l'algorithme Clip grid with polygon
'NoneType' object has no attribute 'crs'



j'ai lu un conseil de désactivation de keep_resolution pour un autre algorithm tiré de gdal nommé ClipByMask.

je ne sais pas comment désactiver "keep_resolution" si ce paramètre existe dans le fichier GeoAlgorithm.py


merci de votre aide précieuse
Anne

Hors ligne

 

Pied de page des forums

Powered by FluxBB

Partagez  |