Nous utilisons des cookies pour vous garantir la meilleure expérience sur notre site. Si vous continuez à utiliser ce dernier, nous considèrerons que vous acceptez l'utilisation des cookies. J'ai compris ! ou En savoir plus !.
Nom d'utilisateur    Mot de passe              Toujours pas inscrit ?   Mot de passe oublié ?

#1 jeu. 07 juin 2018 07:56

grunt
Membre
Date d'inscription: 9 nov. 2010
Messages: 38

[Geoserver] Démarre avec d mauvais caractères UTF-8 sous Debian

Bonjour,


Je me suis fait une VM Vagrant avec ces instructions d'installation de Geoserver :


    sudo sed -i "s/us/fr/g" /etc/default/keyboard
    echo "Europe/Paris" | sudo tee /etc/timezone

    sudo apt-get update -y -qq
    sudo apt-get dist-upgrade -y
    sudo apt-get install apt-transport-https ca-certificates -y
   
    sudo apt-get install unzip -y
    sudo apt-get install curl -y
    sudo apt-get install net-tools -y
    sudo apt-get install openjdk-8-jre openjdk-8-jdk -y
    sudo update-alternatives --config java
    sudo update-alternatives --config javac
   
    export GEOSERVER_VERSION=2.13.0
    export GEOSERVER_DOWNLOAD_URL=https://build.geoserver.org/geoserver/release/$GEOSERVER_VERSION/geoserver-$GEOSERVER_VERSION-bin.zip
   
    curl --silent $GEOSERVER_DOWNLOAD_URL -o geoserver.zip
    sudo unzip geoserver.zip  -d /usr/share
    sudo mv /usr/share/geoserver-$GEOSERVER_VERSION /usr/share/geoserver
    echo 'export GEOSERVER_HOME=/usr/share/geoserver' >> /home/vagrant/.profile
    echo 'export LC_ALL=fr_FR.UTF-8' >> /home/vagrant/.profile
    echo 'export LANG=fr_FR.UTF-8' >> /home/vagrant/.profile
    echo 'export LANGUAGE=fr_FR.UTF-8' >> /home/vagrant/.profile
    sudo chown -R vagrant:vagrant /usr/share/geoserver/   
    cd $GEOSERVER_HOME/bin
    sh startup.sh


Geoserver démarre, mais à la différence de ce qui se passe si je suis sous Windows, ses caractères sont corrompus.

Ce service GeoServer appartient � The Ancient Geographers.

écrit-il, par exemple, en page d'accueil.
Je cherche côté Debian, je cherche côté Geoserver, et je ne trouve pas où une déclaration UTF-8 pourrait manquer.

Merci si vous avez des idées !

Hors ligne

 

#2 jeu. 07 juin 2018 23:15

FlorianD
Moderateur
Date d'inscription: 22 déc. 2016
Messages: 79
Site web

Re: [Geoserver] Démarre avec d mauvais caractères UTF-8 sous Debian

Bonsoir,

patch v2.13.1 http://geoserver.org/release/stable/

Cdlt,

FD

Hors ligne

 

#3 ven. 08 juin 2018 08:37

grunt
Membre
Date d'inscription: 9 nov. 2010
Messages: 38

Re: [Geoserver] Démarre avec d mauvais caractères UTF-8 sous Debian

Merci beaucoup !
Je n'y aurais pas pensé ! Avec une divergence de comportement entre Windows et Debian,
c'était mes compétences Debian que je mettais en cause.

Marc.

Hors ligne

 

Pied de page des forums

Powered by FluxBB

Partagez  |