Nous utilisons des cookies pour vous garantir la meilleure expérience sur notre site. Si vous continuez à utiliser ce dernier, nous considèrerons que vous acceptez l'utilisation des cookies. J'ai compris ! ou En savoir plus !.
Nom d'utilisateur    Mot de passe              Toujours pas inscrit ?   Mot de passe oublié ?

Annonce

Rencontres des Utilisateurs Francophones de QGIS 2019 à Montpellier

12 et 13 décembre 2019 à Montpellier.

Cet événement est organisé en partenariat entre Montpellier SupAgro et l’OSGeo-fr.

http://conf.qgis.osgeo.fr/

 

#1 Tue 21 May 2019 21:40

avel
Membre
Date d'inscription: 21 May 2019
Messages: 1

pb osm2pgsql

Bonjour à tous

Je suis en train d'importer ds postgresql/postgis un fichier osm.pbf. J'ai l'erreur suivante qui apparait:


C:UsersFERON PAPEL Avel>osm2pgsql -U postgres -W -m -d osmBis -p osmBis -E 3857 -S "C:ms4wtoolsosm2pgsqldefault.style" C:ms4wappsosmfrance-latest.osm.pbf
osm2pgsql version 0.96.0 (64 bit id space)

!! You are running this on 32bit system, so at most
!! 3GB of RAM can be used. If you encounter unexpected
!! exceptions during import, you should try running in slim
!! mode using parameter -s.
Password:
Allocating memory for sparse node cache
Node-cache: cache=800MB, maxblocks=12800*65536, allocation method=1
Using built-in tag processing pipeline
Using projection SRS 3857 (Spherical Mercator)
Setting up table: osmBis_point
node cache: stored: 0(-nan(ind)%), storage efficiency: -nan(ind)% (dense blocks: 0, sparse nodes: 0), hit rate: -nan(ind)%
Osm2pgsql failed due to ERROR: CREATE UNLOGGED TABLE osmBis_point (osm_id int8,"access" text,"addr:housename" text,"addr:housenumber" text,"addr:interpolation" text,"admin_level" text,"aerialway" text,"aeroway" text,"amenity" text,"area" text,"barrier" text,"bicycle" text,"brand" text,"bridge" text,"boundary" text,"building" text,"capital" text,"construction" text,"covered" text,"culvert" text,"cutting" text,"denomination" text,"disused" text,"ele" text,"embankment" text,"foot" text,"generator:source" text,"harbour" text,"highway" text,"historic" text,"horse" text,"intermittent" text,"junction" text,"landuse" text,"layer" text,"leisure" text,"lock" text,"man_made" text,"military" text,"motorcar" text,"name" text,"natural" text,"office" text,"oneway" text,"operator" text,"place" text,"population" text,"power" text,"power_source" text,"public_transport" text,"railway" text,"ref" text,"religion" text,"route" text,"service" text,"shop" text,"sport" text,"surface" text,"toll" text,"tourism" text,"tower:type" text,"tunnel" text,"water" text,"waterway" text,"wetland" text,"width" text,"wood" text,"z_order" int4,"population" text,way geometry(POINT,3857) ) WITH ( autovacuum_enabled = FALSE ) failed: ERREUR:  la colonne ┬½ population ┬╗ est sp├®cifi├®e plus d'une fois


Queslqu'un a til eu déjà un pb similaire?

Merci beaucoup

Hors ligne

 

#2 Mon 02 December 2019 18:58

Emgeo
Membre
Date d'inscription: 22 Apr 2016
Messages: 9

Re: pb osm2pgsql

Bonsoir.

Il semble qu'il y ait une erreur dans le code au niveau de la colonne "population",

Osm2pgsql failed due to ERROR: CREATE UNLOGGED TABLE osmBis_point (osm_id int8,"access" text,"addr:housename" text,"addr:housenumber" text,"addr:interpolation" text,"admin_level" text,"aerialway" text,"aeroway" text,"amenity" text,"area" text,"barrier" text,"bicycle" text,"brand" text,"bridge" text,"boundary" text,"building" text,"capital" text,"construction" text,"covered" text,"culvert" text,"cutting" text,"denomination" text,"disused" text,"ele" text,"embankment" text,"foot" text,"generator:source" text,"harbour" text,"highway" text,"historic" text,"horse" text,"intermittent" text,"junction" text,"landuse" text,"layer" text,"leisure" text,"lock" text,"man_made" text,"military" text,"motorcar" text,"name" text,"natural" text,"office" text,"oneway" text,"operator" text,"place" text,"population" text,"power" text,"power_source" text,"public_transport" text,"railway" text,"ref" text,"religion" text,"route" text,"service" text,"shop" text,"sport" text,"surface" text,"toll" text,"tourism" text,"tower:type" text,"tunnel" text,"water" text,"waterway" text,"wetland" text,"width" text,"wood" text,"z_order" int4,"population" text,way geometry(POINT,3857) ) WITH ( autovacuum_enabled = FALSE ) failed: ERREUR:  la colonne ┬½ population ┬╗ est sp├®cifi├®e plus d'une fois


peut-être que c'est au niveau du fichier de style ? Il peut y avoir une redondance d'information à l'intérieur sur l'intitulé de champs.

Hors ligne

 

Pied de page des forums

Powered by FluxBB

Partagez  |