Nous utilisons des cookies pour vous garantir la meilleure expérience sur notre site. Si vous continuez à utiliser ce dernier, nous considèrerons que vous acceptez l'utilisation des cookies. J'ai compris ! ou En savoir plus !.
Nom d'utilisateur    Mot de passe              Toujours pas inscrit ?   Mot de passe oublié ?

Annonce

Le portail retrouve peu à peu ses fonctionnalités.

Les listes ne fonctionnent pas mais nous mettons tout en oeuvre pour les réactiver rapidement.

Si vous avez pris contact avec l'association (petite enveloppe en haut/droite), sachez que nous lisons vos messages mais que les mails ne partent pas (#bug).

Ne soyez pas surpris si vous ne recevez pas de réponse.

#1 Fri 07 June 2019 06:02

Abdoulayi111
Membre
Date d'inscription: 17 Oct 2018
Messages: 5

QGIS 2.18.25: Impossible de charger PyQt ?

Impossible de charger PyQt.
Le support Python va être désactivé.

Traceback (most recent call last):
  File "", line 1, in
RuntimeError: the sip module implements API v10.0 but the PyQt4.QtCore module requires API v11.2

Version de QGIS :
2.18.25 'Las Palmas', cbd7adecf2

Chemin vers Python :
['C:/PROGRA~1/QGIS2~1.18/apps/qgis-ltr/./python', u'C:/Users/Abdoulayi.SOUMARE/.qgis2/python', u'C:/Users/Abdoulayi.SOUMARE/.qgis2/python/plugins', 'C:/PROGRA~1/QGIS2~1.18/apps/qgis-ltr/./python/plugins', 'C:\PROGRA~1\QGIS2~1.18\bin\python27.zip', 'C:\PROGRA~1\QGIS2~1.18\apps\Python27\DLLs', 'C:\PROGRA~1\QGIS2~1.18\apps\Python27\lib', 'C:\PROGRA~1\QGIS2~1.18\apps\Python27\lib\plat-win', 'C:\PROGRA~1\QGIS2~1.18\apps\Python27\lib\lib-tk', 'C:\PROGRA~1\QGIS2~1.18\bin', 'C:\Users\Abdoulayi.SOUMARE\AppData\Roaming\Python\Python27\site-packages', 'C:\PROGRA~1\QGIS2~1.18\apps\Python27', 'C:\PROGRA~1\QGIS2~1.18\apps\Python27\lib\site-packages', 'C:\PROGRA~1\QGIS2~1.18\apps\Python27\lib\site-packages\jinja2-2.7.2-py2.7.egg', 'C:\PROGRA~1\QGIS2~1.18\apps\Python27\lib\site-packages\markupsafe-0.23-py2.7-win-amd64.egg', 'C:\PROGRA~1\QGIS2~1.18\apps\Python27\lib\site-packages\win32', 'C:\PROGRA~1\QGIS2~1.18\apps\Python27\lib\site-packages\win32\lib', 'C:\PROGRA~1\QGIS2~1.18\apps\Python27\lib\site-packages\Pythonwin', 'C:\PROGRA~1\QGIS2~1.18\apps\Python27\lib\site-packages\Shapely-1.2.18-py2.7-win-amd64.egg', 'C:\PROGRA~1\QGIS2~1.18\apps\Python27\lib\site-packages\wx-2.8-msw-unicode', 'C:\PROGRA~1\QGIS2~1.18\apps\Python27\lib\site-packages\xlrd-0.9.2-py2.7.egg', 'C:\PROGRA~1\QGIS2~1.18\apps\Python27\lib\site-packages\xlwt-0.7.5-py2.7.egg']

Hors ligne

 

#2 Fri 07 June 2019 07:15

Patrice
JeSuisCharlie
Date d'inscription: 16 Sep 2005
Messages: 4106

Re: QGIS 2.18.25: Impossible de charger PyQt ?

Bonjour

Comment allez vous ?

GeoBye, Pat


(Autodesk Expert Elite Team)

Hors ligne

 

#3 Fri 07 June 2019 09:28

Abdoulayi111
Membre
Date d'inscription: 17 Oct 2018
Messages: 5

Re: QGIS 2.18.25: Impossible de charger PyQt ?

Bonjour,

Désolé mon message était parti sans que je ne puisse ajouter des commentaires supplémentaires.

Actuellement, je n'arrive plus à utiliser Qgis convenablement. A chaque démarrage de Qgis, le message d'erreur, ci-dessous, apparait.
Ainsi, la plupart des fonctionnalités de Qgis deviennent indisponibles, inutilisables.
J'ai QGis 2.18 et aussi  2.14. Je ne souhaite pas passer à Qgis 3, pour rester en conformité avec mes collègues qui utilise tous, Qgis 2.14.18.

Je désinstalle entièrement Qgis et Python et et ses modules, mais mes problèmes persistent encore.

Merci de votre aide.

Hors ligne

 

#4 Fri 07 June 2019 09:54

Abdoulayi111
Membre
Date d'inscription: 17 Oct 2018
Messages: 5

Re: QGIS 2.18.25: Impossible de charger PyQt ?

Enfin; mon problème a été résolu.
Le module sip faisait référence au répertoire C:\Users\~\AppData\Roaming\Python que je n'avais pas supprimé.
Après la suppression de ce répertoire, tout fonctionne.

En espérant que cette solution sera utile dans l'avenir à d'autres personnes.
Bonne journée

Hors ligne

 

Pied de page des forums

Powered by FluxBB

Partagez  |