Nous utilisons des cookies pour vous garantir la meilleure expérience sur notre site. Si vous continuez à utiliser ce dernier, nous considèrerons que vous acceptez l'utilisation des cookies. J'ai compris ! ou En savoir plus !.
banniere

Le portail francophone de la géomatique


Toujours pas inscrit ? Mot de passe oublié ?
Nom d'utilisateur    Mot de passe              Toujours pas inscrit ?   Mot de passe oublié ?

#1 Sat 18 December 2021 02:02

aerobic83
Juste Inscrit !
Date d'inscription: 1 May 2017
Messages: 8

Problème d'export d'une photo en pop-up liée à un point

Bonjour,

Depuis peu j'essaye de mener à bien un projet personnel de webmapping gratuit donc voici ma problématique.

J'ai souhaité créé une carte avec un point ouvrant un pop-up si l'on clic dessus et permettant de visualiser une photo.
Pour cela j'ai utilisé l'extension ImportPhotos et l'ouverture de la photo marche bien en utilisant le bouton "click photos".

Pour pouvoir mettre cette carte contenant un point avec ma photo dans un hébergeur de données en ligne, il faut d'abord que je prépare la donnée. Pour ce faire, j'ai installé l'extension "qgis2web". Je suis sur QGIS 3.14.16 et mon dossier de travail, ainsi que QGIS, sont installés sur le disque D.
Je clic sur "create web map" de l'application "qgis2web" comme présenté dans la vidéo et je fais exactement les mêmes actions.
https://youtu.be/WFO3Xe0uD5k?t=147

Le chargement se passe bien sauf qu'avant, et plus exactement pendant la prévisualisation, j'ai cliqué sur le point contenant la photo et celle-ci ne s'affiche pas et forme un carré blanc avec un point d'interrogation. Après l'export,  je reclique à nouveau sur le point et que je constate le même problème de la fenêtre pop-up qui n'affiche pas la photo mais à la place un fond blanc avec un carré contenant un point d'interrogation.
Dès lors je n'ai pas poursuivie le webmapping car mon objectif est de faire la carte avec le point et son pop-up contenant la photo.

Savez-vous d'où pourrez provenir ce problème et comment le solutionner ?
Je ne pense pas que ce soit lié au fait que mon QGIS et les documents de travail soient installés et rangé dans le disque D.

Pour ce qui est de la mise en ligne, j'ai regardé rapidement la vidéo suivante ...
https://www.youtube.com/watch?v=eVT0UfeurOE
... et normalement il faudra que je trouve un site qui héberge les données de l'Index, qui me permet d'importer mes fichiers et qui me permet de créer simplement un site internet pour agencer le rendu comme bon mon semble grâce à l'utilisation des langages HTML et PHP.

D'ailleurs, avez vous des noms de sites qui permettent d'héberger gratuitement ce type de données et de faire un site internet pour présenter quelques résultats de travaux en webmapping ?

Cordialement,

Hors ligne

 

Pied de page des forums

Powered by FluxBB