Nous utilisons des cookies pour vous garantir la meilleure expérience sur notre site. Si vous continuez à utiliser ce dernier, nous considèrerons que vous acceptez l'utilisation des cookies. J'ai compris ! ou En savoir plus !.
Nom d'utilisateur    Mot de passe              Toujours pas inscrit ?   Mot de passe oublié ?

Annonce

Si vous lisez ce message, cela signifie que vous êtes sur le nouveau serveur de GeoRezo.

Toutefois, suite à la migration, des anomalies voire des régressions existent et seront corrigées progressivement.

Merci de votre patience.

#1 Thu 18 October 2018 15:27

Sylther
Membre
Lieu: paris
Date d'inscription: 17 May 2016
Messages: 47

QGIS Server, lizmap et Nginx

Bonjour,

Je me bats depuis plusieurs jours avec la config d'un LEMP destiné à accueillir un qgis_server et une instance de lizmap.

Bien qu'ayant parcouru en long en large et en travers  les docs officielles  de Lizmap et de QGIS server (et trouvé quelques coquilles pour lesquelles je ferai des commits), je ne parviens à créer un fichier de config Nginx qui va bien.

Soit la page projet de Lizmap s'affiche mais le lien avec qgis server  n'est pas opérant, soit le qgis server  tourne (et je peux charger une couche en wms dans Qgis desktop , mais je ne parviens plus à charger l'interface Lizmap.

Je serai preneur d'un modèle de fichier conf de Nginx qui fonctionne (idéalement avec un lizmap à la racine (\) du serveur.

Sinon, voici mon *.conf qui permet d'accéder au QGis server en wms (QGis desktop 3.2) mais plante lorsque l'on veut visualiser via lizmap (serveur   :

Code:

server {
    server_name montld;

    access_log   /var/log/nginx/data-access.log;
    error_log    /var/log/nginx/data-error.log error;

    index index.html index.php;
    root /var/www/html/;

    location / {
        root /var/www/html/;

        gzip            off;
        include         fastcgi_params;
        fastcgi_pass    unix:/var/run/fcgiwrap.socket;
        fastcgi_param   SCRIPT_FILENAME /usr/lib/cgi-bin/qgis_mapserv.fcgi;

        fastcgi_param   QGIS_SERVER_LOG_FILE
/var/log/qgisserver/qgis-data.log;
        fastcgi_param   QGIS_SERVER_LOG_LEVEL 0;
        fastcgi_param   QGIS_DEBUG 1;
        fastcgi_param   DISPLAY ":99";
    }

    location ~* /\w+\.php {
        fastcgi_split_path_info ^(.+\.php)(/.+)$;
        set $path_info $fastcgi_path_info; # because of bug
http://trac.nginx.org/nginx/ticket/321

        try_files    $fastcgi_script_name =404;
        include        fastcgi_params;

        fastcgi_index    index.php;
        fastcgi_param    SCRIPT_FILENAME $document_root$fastcgi_script_name;
        fastcgi_param    SERVER_NAME lizmap;
        fastcgi_param    PATH_INFO $path_info;
        fastcgi_param    PATH_TRANSLATED $document_root$path_info;
        fastcgi_pass    unix:/run/php/php7.0-fpm.sock;
    }
   
}

Merci d'avance pour toute piste !
Bonne journée,
S.

Dernière modification par Sylther (Wed 24 October 2018 01:22)

Hors ligne

 

Pied de page des forums

Powered by FluxBB

Partagez  |