Nous utilisons des cookies pour vous garantir la meilleure expérience sur notre site. Si vous continuez à utiliser ce dernier, nous considèrerons que vous acceptez l'utilisation des cookies. J'ai compris ! ou En savoir plus !.
Nom d'utilisateur    Mot de passe              Toujours pas inscrit ?   Mot de passe oublié ?

Annonce

Le GeoRezo vous souhaite une bonne année 2020 !

voeux2020

#1 Tue 23 July 2019 15:19

Miich
Membre
Lieu: Lille
Date d'inscription: 22 Jul 2010
Messages: 14

Lizmap - Pas d'icône d'impression

Bonjour,

Après plusieurs recherches, je fais appel à la communauté Georezo.
Nous utilisons Lizmap 3.2.3 avec Qgis Server 2.18. Nous sommes en version LTR de Qgis (3.4.10).

Nous n'avions jamais eu besoin de l'impression sous Lizmap.
Pour un de nos projets, nos cartes nécessitent l'impression.
Nous avons fait la configuration comme recommandé sur la documentation :
- il y a un composeur d’impression qui contient titre, légende et carte,
- l'outil impression est bien coché dans l'onglet carte du plugin lizmap,
- les échelles sont bien définies dans l'onglet carte du plugin lizmap.

Aucun composeur d'impression n'est exclu dans les propriétés du projet.

Est-ce que quelqu'un a déjà rencontré le problème?
Avez-vous une solution pour le corriger?

Merci d'avance.

Hors ligne

 

#2 Thu 05 September 2019 20:38

Floflo49fb
Membre
Lieu: Montpellier
Date d'inscription: 29 Aug 2009
Messages: 227
Site web

Re: Lizmap - Pas d'icône d'impression

Bonjour,
Vous travaillez avec QGIS 3.4 et votre serveur tourne sur la 2.18 est ce que ce n'est pas ça le problème?


Florian Boret
Dream it, Make it, Share it

Hors ligne

 

#3 Tue 10 September 2019 14:06

Miich
Membre
Lieu: Lille
Date d'inscription: 22 Jul 2010
Messages: 14

Re: Lizmap - Pas d'icône d'impression

Bonjour,

Merci pour votre réponse. En effet, c'est une bonne idée, j'avoue ne pas y avoir pensé.
Nous avons donc testé l'installation de qgis server 3.4.
Nous sommes sur un serveur windows et nous avons rencontré pas mal de soucis à l'installation.
Nous sommes bloqués sur le problème suivant : lorsque nous souhaitons voir la carte (produite en interne ou celle de la démo, la publication ne se termine jamais et nous pouvons voir en fond l'erreur "Internal Servor Error".
Quelqu'un aurait-il réussi l'installation de qgis server 3 sur un serveur windows?
nous avons déjà testé pas mal de solutions proposées sur les forums et nous n'avons pas solutionné le problème.

Merci d'avance.

Hors ligne

 

#4 Wed 11 September 2019 12:18

Blaise Picinbono
Membre
Date d'inscription: 8 Jan 2015
Messages: 47
Site web

Re: Lizmap - Pas d'icône d'impression

Bonjour;

Vous devez avoir un ficher journal (log) des erreurs du serveur web (quel est-il ? apache ?), et un autre spécifique à Lizmap.
Quelles sont le erreurs affichées dans ces fichiers lors de la publication ?

Une méthode pratique de débogage est d'afficher en direct les nouvelles lignes écrites dans ces fichiers journaux d'erreurs.
Le lien suivant décrit quelques outils (non exhaustifs) pour faire cela:
https://stackify.com/13-ways-to-tail-a- … dows-unix/

Hors ligne

 

#5 Mon 23 September 2019 10:06

Miich
Membre
Lieu: Lille
Date d'inscription: 22 Jul 2010
Messages: 14

Re: Lizmap - Pas d'icône d'impression

Bonjour,

Merci pour votre réponse. Je ne gère pas le côté installation et serveur c'est notre informaticien. Du coup après avoir cherché et tenté plusieurs solutions, il va installer ubuntu qui semble mieux accepter l'installation de QGis Server. Je vous ferai un retour quand tout sera réinstallé.

Hors ligne

 

#6 Tue 24 September 2019 17:15

l.fatoux
Membre
Date d'inscription: 24 Sep 2019
Messages: 1

Re: Lizmap - Pas d'icône d'impression

Blaise Picinbono a écrit:

Bonjour;

Vous devez avoir un ficher journal (log) des erreurs du serveur web (quel est-il ? apache ?), et un autre spécifique à Lizmap.
Quelles sont le erreurs affichées dans ces fichiers lors de la publication ?

Une méthode pratique de débogage est d'afficher en direct les nouvelles lignes écrites dans ces fichiers journaux d'erreurs.
Le lien suivant décrit quelques outils (non exhaustifs) pour faire cela:
https://stackify.com/13-ways-to-tail-a- … dows-unix/


Bonjour,

je suis l'informaticien de Miich,
le serveur apache fonctionné correctement aucun problème lizmap également, j'ai même testé avec un serveur nginx
le problème se situe au niveau de l'installation de qgis serveur LTR
le simple fait de faire l'installation et de me rendre sur le lien :
http://localhost/qgis/qgis_mapserv.fcgi.exe
ne fonctionne pas j'ai un retour d'erreur
j'ai testé avec un DEBIAN 9 pareille
je suis revenu sur un LTR 2.18 aucun problème.

Hors ligne

 

#7 Wed 25 September 2019 08:17

chanteclair
Membre
Lieu: Pau
Date d'inscription: 3 Jan 2007
Messages: 421

Re: Lizmap - Pas d'icône d'impression

Bonjour,
Vous devriez poster votre demande sur le github de 3Liz :

https://github.com/3liz/lizmap-web-client

En farfouillant vous trouverez peut-être des éléments de réponse en attendant la réponse de 3Liz directement.
Cordialement.

Hors ligne

 

#8 Wed 25 September 2019 12:21

Blaise Picinbono
Membre
Date d'inscription: 8 Jan 2015
Messages: 47
Site web

Re: Lizmap - Pas d'icône d'impression

l.fatoux a écrit:

le simple fait de faire l'installation et de me rendre sur le lien :
http://localhost/qgis/qgis_mapserv.fcgi.exe
ne fonctionne pas j'ai un retour d'erreur


Bonjour;

Qui a-t-il d'écrit dans les logs d'erreur d'apache à ce moment là (sur Windows et Debian) ?

En parcourant la section "issues" du github de lizamp, on trouve ce fil qui semble se rapprocher de votre problème:

https://github.com/3liz/lizmap-web-client/issues/1327

A la fin, gioman parle d'une magic recipe ??? Vous devriez peut-être vous rapprocher de cette personne ?

Rien n'est simple, et c'est toujours agaçant lorsqu'avec de nouvelles versions, ça ne fonctionne plus aussi bien qu'avant.
Bon courage !

Dernière modification par Blaise Picinbono (Wed 25 September 2019 13:00)

Hors ligne

 

#9 Mon 30 September 2019 23:58

Blaise Picinbono
Membre
Date d'inscription: 8 Jan 2015
Messages: 47
Site web

Re: Lizmap - Pas d'icône d'impression

Bonjour;

Une bonne nouvelle peut-être pour vous est tombée sur le ReLucBlog aujourd'hui, repris sur la page d'accueil de georezo:

https://www.3liz.com/blog/rldhont/index … compatible

Vous devriez essayer d'installer ces nouvelles versions

Hors ligne

 

#10 Wed 02 October 2019 08:46

Miich
Membre
Lieu: Lille
Date d'inscription: 22 Jul 2010
Messages: 14

Re: Lizmap - Pas d'icône d'impression

Bonjour,

Merci pour cette information. Notre configuration actuelle fonctionnant correctement, nous allons certainement continuer comme ça. Mais nous allons regarder le lien au cas où.

Hors ligne

 

Pied de page des forums

Powered by FluxBB

Partagez  |