Nous utilisons des cookies pour vous garantir la meilleure expérience sur notre site. Si vous continuez à utiliser ce dernier, nous considèrerons que vous acceptez l'utilisation des cookies. J'ai compris ! ou En savoir plus !.
Nom d'utilisateur    Mot de passe              Toujours pas inscrit ?   Mot de passe oublié ?

Annonce

GeoRezo est partenaire institutionnel de la Conférence Francophone ESRI

image sig2019

16 et 17 octobre 2019 aux Docks de Paris

#1 Tue 23 July 2019 15:19

Miich
Membre
Lieu: Lille
Date d'inscription: 22 Jul 2010
Messages: 12

Lizmap - Pas d'icône d'impression

Bonjour,

Après plusieurs recherches, je fais appel à la communauté Georezo.
Nous utilisons Lizmap 3.2.3 avec Qgis Server 2.18. Nous sommes en version LTR de Qgis (3.4.10).

Nous n'avions jamais eu besoin de l'impression sous Lizmap.
Pour un de nos projets, nos cartes nécessitent l'impression.
Nous avons fait la configuration comme recommandé sur la documentation :
- il y a un composeur d’impression qui contient titre, légende et carte,
- l'outil impression est bien coché dans l'onglet carte du plugin lizmap,
- les échelles sont bien définies dans l'onglet carte du plugin lizmap.

Aucun composeur d'impression n'est exclu dans les propriétés du projet.

Est-ce que quelqu'un a déjà rencontré le problème?
Avez-vous une solution pour le corriger?

Merci d'avance.

Hors ligne

 

#2 Thu 05 September 2019 20:38

Floflo49fb
Membre
Lieu: Montpellier
Date d'inscription: 29 Aug 2009
Messages: 217
Site web

Re: Lizmap - Pas d'icône d'impression

Bonjour,
Vous travaillez avec QGIS 3.4 et votre serveur tourne sur la 2.18 est ce que ce n'est pas ça le problème?


Florian Boret
Dream it, Make it, Share it

Hors ligne

 

#3 Tue 10 September 2019 14:06

Miich
Membre
Lieu: Lille
Date d'inscription: 22 Jul 2010
Messages: 12

Re: Lizmap - Pas d'icône d'impression

Bonjour,

Merci pour votre réponse. En effet, c'est une bonne idée, j'avoue ne pas y avoir pensé.
Nous avons donc testé l'installation de qgis server 3.4.
Nous sommes sur un serveur windows et nous avons rencontré pas mal de soucis à l'installation.
Nous sommes bloqués sur le problème suivant : lorsque nous souhaitons voir la carte (produite en interne ou celle de la démo, la publication ne se termine jamais et nous pouvons voir en fond l'erreur "Internal Servor Error".
Quelqu'un aurait-il réussi l'installation de qgis server 3 sur un serveur windows?
nous avons déjà testé pas mal de solutions proposées sur les forums et nous n'avons pas solutionné le problème.

Merci d'avance.

Hors ligne

 

#4 Wed 11 September 2019 12:18

Blaise Picinbono
Membre
Date d'inscription: 8 Jan 2015
Messages: 38
Site web

Re: Lizmap - Pas d'icône d'impression

Bonjour;

Vous devez avoir un ficher journal (log) des erreurs du serveur web (quel est-il ? apache ?), et un autre spécifique à Lizmap.
Quelles sont le erreurs affichées dans ces fichiers lors de la publication ?

Une méthode pratique de débogage est d'afficher en direct les nouvelles lignes écrites dans ces fichiers journaux d'erreurs.
Le lien suivant décrit quelques outils (non exhaustifs) pour faire cela:
https://stackify.com/13-ways-to-tail-a- … dows-unix/

Hors ligne

 

Pied de page des forums

Powered by FluxBB

Partagez  |