Nous utilisons des cookies pour vous garantir la meilleure expérience sur notre site. Si vous continuez à utiliser ce dernier, nous considèrerons que vous acceptez l'utilisation des cookies. J'ai compris ! ou En savoir plus !.
Nom d'utilisateur    Mot de passe              Toujours pas inscrit ?   Mot de passe oublié ?

Annonce

GeoRezo est partenaire institutionnel de la Conférence Francophone ESRI

image sig2019

16 et 17 octobre 2019 aux Docks de Paris

#1 Mon 11 December 2017 21:08

raster31
Membre
Date d'inscription: 13 Oct 2016
Messages: 19

bug affichage photos - Lizmap en local

Bonjour à tous,

J'ai l'habitude de bosser avec Lizmap, très bonne appli carto_web que je recommande. Je précise que je n'ai pas le problème que je vais vous énoncer lorsque j'ai hébergé toutes mes cartes sur les serveurs mutualisés de 3Liz...

Mais dans le cadre d'un projet, je dois travailler pour le moment en local (apache 2.4 et php-5.6.30 sous windows), tout marche très bien sauf l’affichage des photos dans les miniatures au niveau des pop up.
Ce sont des photos que je télécharge lorsque je fais des éditions (je pense avoir tout bien paramétré dans ma bdd postgis et dans mon projet qgis) et si je clique sur l’icône où la photo devrait apparaitre j’ai une autre fenêtre qui s’ouvre dans mon navigateur avec l’url suivante :

http://localhost/index.php/view/media/getMedia?repository=ino&project=ino_mapping&path=media%2Fupload%2Fino_mapping%2Fpolygones%2Fphotos%2Fnorth_arrows.png

et le message d’erreur suivant :

error    "403 forbidden (you're not allowed to access to this media)"
message    "Vous n'avez pas les droits pour voir ce répertoire de cartes."
   
En fouillant sur le net, j’ai trouvé que je devais autoriser les accès dans certains fichiers notamment httpd.conf (de denied à granted) et dans php.ini (de off à on) mais après ces modifs et en ayant redémarré Apache, ça ne marche tjrs pas.

Par contre quand je vais dans la table attributaire et que je clique sur le lien « photos » dans le champ concerné, j’ai bien ma photo qui s’affiche dans une autre fenêtre de mon navigateur avec l’url suivante :

http://192.168.111.181/index.php/view/m … arrows.png

Du coup, j’ai inspecté l’élément (càd la miniature qui ne s’affiche pas dans le pop up) et j’ai bien cette url qui apparait :

<img src =  http://localhost/index.php/view/media/getMedia?repository=ino&project=ino_mapping&path=media%2Fupload%2Fino_mapping%2Fpolygones%2Fphotos%2Fnorth_arrows.png” border=”0”>

Du coup, le problème viendrait peut être de ça : le terme localhost dans l’url semble bloquer l’affichage alors que lorsqu’il y a l’ip de mon serveur local à savoir 192.168.111.181 ce serait bon.

Ça n’a peut-être rien à voir mais c’est la seule piste que j’ai…

Je précise en outre que mes photos au moment du téléchargement vont bien se ranger dans le dossier media/upload/… de mon projet Qgis.

Si quelqu'un a une piste pour résoudre ce ptit problème, je suis preneur!

Merci par avance.

PS : je précise que dans la doc de Lizmap, on parle de cela :

Give Apache user (usually www-data) write permission on the upload folder, so that it can create files and folders in media/upload:

chmod 775 -R media/upload && chown :www-data -R media/upload


mais je ne vois pas dans quel fichier je dois entrer (www-data!???)

Hors ligne

 

#2 Thu 14 December 2017 16:18

raster31
Membre
Date d'inscription: 13 Oct 2016
Messages: 19

Re: bug affichage photos - Lizmap en local

solution apportée par 3Liz :

* Vérifier dans la configuration Apache que le servername est bien l'IP et non locahost. Si non, corriger et recharger Apache
* Aller dans la racine de Lizmap, et lancer la commande pour nettoyer le cache (à faire en tant que root) : lizmap/install/clean_vartmp.sh
* Dans son navigateur, lancer une carte Lizmap avec l'IP (et plus jamais avec localhost) (en forçant la non utilisation du cache via CTRL + R pour rafraichir)
* Vérifier dans la source de la page (CTRL + U) que tous les liens sont avec l'IP et non localhost (chercher le mot localhost pour vérifier)

ça marche!

Dernière modification par raster31 (Thu 14 December 2017 16:29)

Hors ligne

 

Pied de page des forums

Powered by FluxBB

Partagez  |