Nous utilisons des cookies pour vous garantir la meilleure expérience sur notre site. Si vous continuez à utiliser ce dernier, nous considèrerons que vous acceptez l'utilisation des cookies. J'ai compris ! ou En savoir plus !.
Nom d'utilisateur    Mot de passe              Toujours pas inscrit ?   Mot de passe oublié ?

Annonce

Si vous lisez ce message, cela signifie que vous êtes sur le nouveau serveur de GeoRezo.

Toutefois, suite à la migration, des anomalies voire des régressions existent et seront corrigées progressivement.

Merci de votre patience.

#1 Fri 05 October 2018 15:21

Pivès001
Membre
Date d'inscription: 23 Jan 2008
Messages: 133

[ArcGIS 10.4.1] Encodage des caractères spéciaux

Bonjour,

j'ai des soucis d'encodage de caractères avec ArcGIS, tous les caractères spéciaux pour être exact. Par le passé je m'en accommodais en corrigeant mes tables car je retombais toujours sur les mêmes valeurs mais depuis peu le moindre accent est remplacé par de nombreux autres caractères.

Pour le "é" par exemple j'ai parfois des n, des m, des l, des chiffres ... c'est très variable et ne semble respecter aucune règle récurrente. Et cela à lieu presque à chaque jeu de données que je récupère.

D'autres ont-ils le même soucis ? Si oui comment y remédier ?

C'est très chronophage de corriger les tables, encore plus si cela doit être fait manuellement. J'ai souvenir d'une discussion sur le forum à ce sujet mais impossible de remettre la main dessus.

Bonne journée à toutes/tous.

Hors ligne

 

#2 Fri 05 October 2018 19:08

carteq
Membre
Lieu: Côte-Nord, Québec
Date d'inscription: 8 Mar 2008
Messages: 510

Re: [ArcGIS 10.4.1] Encodage des caractères spéciaux

Les données importées sont dans quel format ? Si en .shp, le .dbf associé est responsable. Convertir vers un .dbf cause souvent ce genre de problème

Obtenir des données en géodatabase évite généralement ce genre de problème.


Vincent Fréchette
Responsable de la géomatique
Boisaco inc.

Hors ligne

 

#3 Mon 08 October 2018 09:25

Pivès001
Membre
Date d'inscription: 23 Jan 2008
Messages: 133

Re: [ArcGIS 10.4.1] Encodage des caractères spéciaux

Bonjour, oui il s'agit de shp, la plupart du temps provenant de divers services de l'Etat ou de collectivités.

La solution serait donc de détecter l'encodage du .dbf et éventuellement de le convertir ?

En me renseignant je suis tombé sur ce sujet, pas inintéressant : http://chinook.memoris.fr/2011/12/ce-db … ccent-e-u/

Edit: je viens de comprendre que l'encodage était précisé dans le fichier .cpg. Il n'existe pas toujours dans le jeu de données, j'ai donc fait le test d'en créer un pour une couche posant problème. A l'intérieur j'ai inscrit "ANSI" (UTF-8 ne donnant rien de mieux) et tous mes caractères spéciaux sont désormais corrects à l'ouverture de ma table.

Dernière modification par Pivès001 (Mon 08 October 2018 10:29)

Hors ligne

 

#4 Tue 09 October 2018 14:47

carteq
Membre
Lieu: Côte-Nord, Québec
Date d'inscription: 8 Mar 2008
Messages: 510

Re: [ArcGIS 10.4.1] Encodage des caractères spéciaux

Belle découverte ! Ça me sera utile également.


Vincent Fréchette
Responsable de la géomatique
Boisaco inc.

Hors ligne

 

Pied de page des forums

Powered by FluxBB

Partagez  |